Pivotal Knowledge Base

Follow

MADlib Version Mismatch After Greenplum Upgrade

Environment

 Product  Version
 Pivotal Greenplum  4.3.x
 OS  RHEL 6.x

Symptom

The following error is seen:

ERROR: incompatible library "/xxx/madlib/Versions/1.6/ports/greenplum/4.2/lib/libmadlib.so": version mismatch (dfmgr.c:385)
DETAIL: Server version is Greenplum 4.3 (header version: 1), library is Greenplum 4.2 (header version: 0). 
ERROR: function madlib.__array_indexed_agg_sfunc(double precision[], double precision, bigint, bigint) does not exist

Cause
MADlib package versions for Greenplum v4.2 & v4.3 are different. When the customer upgrade from Greenplum v4.2 to v4.3, they need to uninstall and then reinstall the correct MADlib package.

Resolution
After uninstalling the old MADlib version, and reinstalling the correct version for gpdb v4.3, the issue should be resolved.

Comments

Powered by Zendesk