Pivotal Knowledge Base

Follow

GPPKG Error: Package plr-1.2.1.0 has Not been Installed

Environment

 Product  Version
 Pivotal Greenplum and Pivotal HDB (HAWQ)  4.3.x and HDB 1.2.x
 OS  RHEL 6.x

Symptom

When attempting to uninstall PL/R 1.2, the action fails with the following error message.

Error Message:

[gpadmin@mdw ]$ gppkg -r plr-1.2.1.0 
20170109:15:49:47:430721 gppkg:mdw:gpadmin-[INFO]:-Starting gppkg with args: -r plr-1.2.1.0 
20170109:15:49:48:430721 gppkg:mdw:gpadmin-[ERROR]:-gppkg error: Package plr-1.2.1.0 has not been installed.

Cause 

There is a known code bug issue that is causing the uninstall of PL/R to fail.

Resolution

Currently, there is no fix for this issue, but there is a workaround for which you would need to modify the gppkg.py file.

First, let's locate the gppkg.py file:

HAWQ location:

/usr/local/hawq/lib/python/gppylib/programs/gppkg.py

Greenplum location:

/usr/local/greenplum-db/lib/python/gppylib/programs/gppkg.py

Find the following line in:

pkg_file_list = ListFilesByPattern(GPPKG_ARCHIVE_PATH, self.remove + '-*-*' + GPPKG_EXTENSION).run()

And then modify the line to match the below example:

pkg_file_list = ListFilesByPattern(GPPKG_ARCHIVE_PATH, self.remove + '-*' + GPPKG_EXTENSION).run()

Retry to uninstall PL/R after making the changes to the gppkg.py file and it should succeed this time around. 

Comments

Powered by Zendesk