Pivotal Knowledge Base

Follow

Greenplum Error "psql: could not connect to server: Permission denied"

Environment

 Product  Version
 Pivotal Greenplum  4.3.x
 OS  RHEL 6.x

Symptom

When running a psql command, it fails with the error message below:

[gpadmin@mdw pg_log]$ psql 
psql: could not connect to server: Permission denied
Is the server running locally and accepting
connections on Unix domain socket "/tmp/.s.PGSQL.5432"?

Cause 

Because Greenplum postgres process will create a temp file under /tmp/ directory, psql would also need to access /tmp/ while starting.

Resolution

After setting /tmp/ directory permission to 777, psql should be working fine again.

 

Comments

Powered by Zendesk