Pivotal Knowledge Base

Follow

FAQ on Pivotal Cloud Foundry Elastic Runtime 1.10 Upgrade Advisory

Environment

Pivotal Cloud Foundry Elastic Runtime v1.9.13

Pivotal Cloud Foundry Elastic Runtime v1.10.0

Overview

This upgrade advisory only applies to users who have installed Pivotal Cloud Foundry Elastic Runtime v1.9.13 and are planning to upgrade to Pivotal Cloud Foundry Elastic Runtime v1.10.0.

There is an unfortunate incompatibility issue when upgrading from precisely Elastic Runtime v1.9.13 to v1.10.0. The issue is now understood and Pivotal is working towards resolving this issue. New deployments of PCF 1.10 or upgrades to Elastic Runtime v.1.10.0 from v1.9.0 through v1.9.12 are not affected by this issue.

Frequently Asked Questions

Q: I have Elastic Runtime v1.9.13, should I wait to upgrade to v1.10.0?

A: Yes, please wait to upgrade to Elastic Runtime v1.10.x until the upgrade fix is in place, which is estimated to be ready in the near future.

 

Q: I have Elastic Runtime v1.9.x, should I not upgrade to v1.9.13?

A: Please do upgrade to Elastic Runtime v1.9.13+ as this contains critical fixes. However, please do not upgrade to Elastic Runtime v1.10.0 until the upgrade fix is in place, which is estimated to be ready in the near future.

 

Q: I have Elastic Runtime v1.9.12 (or below), can I upgrade to v1.10.0?

A: Yes, you can upgrade to Elastic Runtime v1.10.0 without any issues.

 

Q: Can I perform a new deployment of Elastic Runtime v1.10.0?

A: Yes, you can proceed with a new deployment of Elastic Runtime v1.10.0 and will be able to upgrade to any future Elastic Runtime v1.10.x versions.

Comments

Powered by Zendesk