Pivotal Knowledge Base

Follow

Deploying ERT 1.11 fails to due to a timeout error while updating PostGreSQL

Environment

Pivotal Cloud Foundry: 1.11

Symptom

When you are upgrading to ERT 1.11, the deployment fails with the following error:

[2017-06-15 03:59:27+0000] Performing Upgrade
[2017-06-15 03:59:27+0000] ------------------
[2017-06-15 03:59:28+0000] Analyzing all rows in the new cluster ok
[2017-06-15 03:59:28+0000] Freezing all rows on the new cluster ok
[2017-06-15 03:59:29+0000] Deleting files from new pg_clog ok
[2017-06-15 03:59:29+0000] Copying old pg_clog to new server ok
[2017-06-15 03:59:29+0000] Setting next transaction ID and epoch for new cluster ok...
......[2017-06-15 03:59:31+0000] uaa
[2017-06-15 03:59:31+0000] uaa_old
[2017-06-15 03:59:31+0000] ok...
[2017-06-15 03:59:32+0000] Copying user relation files
......[2017-06-15 03:59:32+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768
[2017-06-15 03:59:34+0000] FAIL: DB upgrade stopped in the middle, manual intervention required, quitting...
[2017-06-15 03:59:41+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768.1
[2017-06-15 04:00:00+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768.2....

......[2017-06-15 04:01:11+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768.6
[2017-06-15 04:01:14+0000] FAIL: DB upgrade stopped in the middle, manual intervention required, quitting...

......[2017-06-15 04:04:07+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768_fsm
[2017-06-15 04:04:07+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21768_vm....

......[2017-06-15 04:04:34+0000] FAIL: DB upgrade stopped in the middle, manual intervention required, quitting...
[2017-06-15 04:04:40+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21776_fsm
[2017-06-15 04:04:40+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21777
[2017-06-15 04:05:00+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16416/21777_fsm....

......[2017-06-15 04:05:00+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16417/16667
[2017-06-15 04:05:00+0000] /var/vcap/store/postgres/postgres-9.4.9/base/16417/16669
[2017-06-15 04:05:00+0000] ok
[2017-06-15 04:05:00+0000] Setting next OID for new cluster ok
[2017-06-15 04:05:03+0000] Sync data directory to disk ok
[2017-06-15 04:05:03+0000] Creating script to analyze new cluster ok
[2017-06-15 04:05:03+0000] Creating script to delete old cluster ok
[2017-06-15 04:05:03+0000]
[2017-06-15 04:05:03+0000] Upgrade Complete

Cause

This as an ERT known issue with slower storage, large UAA or CC datasets, and running PG. This issue occurs due to a timeout while updating PostGreSQL in large environments.

Resolution

The workaround to resolve this error is to re-deploy.

 

Comments

Powered by Zendesk