Pivotal Knowledge Base

Follow

Resource Config Page Returns a 500 error

Environment

Pivotal Cloud Foundry 1.11

Operations Manager 1.11

Purpose

When importing previous versions of installation that have non-default VM sizes that are no longer supported on the 1.11 version of Operations Manager, the Resource Config page gets a 500 error.

Resolution

To work around this issue, follow the steps below:

  1. Get the list of the supported VM Types from the previous version of Ops Manager you are exporting from and the current version you are importing to by using "GET /api/v0/vm_types" API endpoint.
  2. Use "PUT /api/v0/vm_types" to update the list of VMs in the current version of Ops Manager to include the missing VM Types. Note that PUT overwrites the default list of VM Types, and make sure to include the full list.
  3. Go to Resource Config tab again, and select another VM that is supported based on the output in step 1.

Comments

Powered by Zendesk