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IP is already used error due to tile not deleting completely

Environment

Pivotal Cloud Foundry 1.9

Symptom

A tile is deleted and then re-deployed and reports errors that IP is already used.

Attempting to re-deploy reports error "IP is already used (ping is returned)"

bosh deployments shows deployment existing that does not exist in OpsManager:

  | cf-02aedca9addcd668a730   | binary-offline-buildpack/1.0.12      | bosh-vsphere-esxi-ubuntu-trusty-go_agent/3363.26 | latest
 | p-metrics-b32b1e25eddff477597b | pcf-jmxbridge-v1.8/300.1.0 | bosh-vsphere-esxi-ubuntu-trusty-go_agent/3363.24 | latest | ...

In above example, metrics exists when viewed by BOSH CLI but not under OpsManager UI.

Cause 

The deployment for the deleted tile did not get removed completely. It still has references to IPs needed for redeployment and there are still VMs deployed in the environment using those IPs.

Resolution

1. Check the running bosh deployments and identify the deployment that does not exist in OpsManager.

# bosh deployments 
 | cf-02aedca9addcd668a730    | binary-offline-buildpack/1.0.12      | bosh-vsphere-esxi-ubuntu-trusty-go_agent/3363.26 | latest 
 | p-metrics-b32b1e25eddff477597b | pcf-jmxbridge-v1.8/300.1.0 | bosh-vsphere-esxi-ubuntu-trusty-go_agent/3363.24 | latest | ...

2. Delete the deployment manually from BOSH perspective:

# bosh delete deployment p-metrics-b32b1e25eddff477597b

3. Once deleted re-run deployment from OpsManager and "IP is already used error" errors should now be resolved.

 

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