Pivotal Knowledge Base

Follow

Load data via gpfdits failed with "Unknown SSL protocol error"

Environment

Greenplum database 4.3.x

Symptom

When attempting to load the large volume of data via gpfdists protocol, after a while it failed with error message “Unknown SSL protocol error”.

Error Message:

2017-08-16 11:56:51.156856 UTC,"gpadmin","gpadmin",p128362,th-262436992,"192.0.2.1","37180",2017-08-16 11:55:02 UTC,3321245,con58397,cmd59,seg15,slice1,dx1696640,x3321245,sx1,"ERROR","08006","connection with gpfdist failed for gpfdists://etl1.example.com:8080/data/batch1/dat1.gz. effective url: https://etl1.example.com:8080/data/batch1/dat1.gz.","Unknown SSL protocol error in connection to etl1.example.com:8080",,,,,"insert into ""table1""(""c1"", ""c2"") select * from ""table1_ex"" 
* Unknown SSL protocol error in connection to etl1.example.com:8080  

Cause

The "max open files" ulimit setting on the server hosting gpfdist service is with a default value (1024), which is not big enough when there are too many data files to load. 

When the limit was reached gpfdist instance could not open a new file for incoming request from Greenplum database side, hence returned "Unknown SSL protocol error". 

Resolution

Adjust "max open files" ulimit setting on the server hosting gpfdist instance and make sure it's big enough for the specific tasks.

Refer to this article Session failures with "Too many open files" for how to adjust this setting. 

Comments

Powered by Zendesk