Pivotal Knowledge Base

Follow

GPCONFIG Errors: "Ident Authentication Failed for User" OR "gpadmin"/fe_sendauth: No Password Supplied"

Environment

 Product  Version
 Pivotal Greenplum  4.3.x, 4.2.x
 OS  RHEL 6.x

Symptom

gpconfig failed and either one of the two error messages are returned:

gpconfig -s max_connections
20140512:09:26:11:024740 gpconfig:smdw:gpadmin-[ERROR]:-Failed to retrieve GUC information: fe_sendauth: no password supplied
gpconfig -s max_connections
20140512:09:24:16:024079 gpconfig:smdw:gpadmin-[ERROR]:-Failed to retrieve GUC information: FATAL: Ident authentication failed for user "gpadmin"

Cause

gpconfig uses the following parameters to access the database:

  • PGHOST
  • PGPORT 
  • PGUSER 
  • PGPASSWORD
  • PGDATABASE

It's access is also controlled by the pg_hba.conf file. This means that when gpconfig tries to connect to the database, it will use the specified username and password (provided by these parameters) to access the specified database (also from the parameter). 

When the first entry for host access is set to ident, gpconfig fails with the error message:

"Ident authentication failed for user 'gpadmin'"

When the first entry for host access is set to md5, and the PGPASSWORD parameter is not setup, gpconfig will fail with the error message:

"fe_sendauth: no password supplied"

Resolution

1. Make the first host entry for 127.0.0.1 and don't set the default database to ident.
2. When the first host entry for 127.0.0.1 and default database is set to MD5, specify the PGPASSWORD parameter.
3. Directly set the first host entry for 127.0.0.1 and default the database to trust.

Once the change is made, run gpstop -u to implement it.

Comments

Powered by Zendesk