Pivotal Knowledge Base

Follow

Installing PCC fails with "Unable to find domain name with facter"

Environment 

  • PHD 1.x

Symptom

When installing Pivotal Command Center on admin node, it fails with below errors

/usr/share/rubygems/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
Traceback (most recent call last):
File "/usr/lib/gphd/gphdmgr/bin/gphdmgr_setup.py", line 68, in 
GphdmgrSetup.execute()
File "/usr/lib/gphd/gphdmgr/bin/gphdmgr_setup.py", line 40, in execute
writer.write()
File "/usr/lib/gphd/gphdmgr/bin/../lib/install/yum_repo_writer.py", line 74, in write
local_repo.write(self.local_repo_content())
File "/usr/lib/gphd/gphdmgr/bin/../lib/install/yum_repo_writer.py", line 56, in local_repo_content
""" % self.vars()
File "/usr/lib/gphd/gphdmgr/bin/../lib/install/yum_repo_writer.py", line 21, in vars
return {"repo_name": self.repo_name(), "rpm_path": self.rpm_path(), "fqdn": self.fqdn()}
File "/usr/lib/gphd/gphdmgr/bin/../lib/install/yum_repo_writer.py", line 26, in fqdn
raise SystemError('Unable to find domain name with facter')
SystemError: Unable to find domain name with facter
Pivotal Command Center did not start correctly.
Please see the log file for more information.

Root Cause

This is because below command returns nothing.

facter --puppet fqdn

Possible cause is FQDN is not configured on admin node.

For example

[root@admin]# hostname -f
admin
[root@admin]# hostname
admin

[root@admin PCC-2.1.0-460]# cat /etc/hosts|grep admin
192.168.192.100 admin

Solution

  1. Configure FQDN on admin node by adding FQDN in /etc/hosts
    [root@admin]# cat /etc/hosts|grep admin
    192.168.192.100 admin.domain.com admin
    
    [root@admin]# hostname
    admin
    [root@admin]# hostname -f
    admin.domain.com
    
  2. Uninstall Pivotal Command Center
    cd PCC-2.1.0-460
    ./uninstall
    
  3. Remove postgresql-server
    yum erase postgresql-server
    rm -rf /var/lib/pgsql
    
  4. Install Pivotal Command Center again 
    cd PCC-2.1.0-460
    ./install
  5. Verify using below command.
    facter --puppet fqdn

Comments

Powered by Zendesk