Pivotal Knowledge Base

Follow

Pivotal Greenplum Installation Error: "GNU tar is Needed to Extract this Installer"

Environment

 Product  Version
 Pivotal Greenplum   4.2.x
 OS  All Supported OS

Overview

Pivotal Greenplum installation (Using the /bin/bash greenplumxxxx.bin command) reports "GNU tar is needed to extract this installer" error.

*****************************************************
Error: GNU tar is needed to extract this installer.
Please add it to your path before running the installer again.
Exiting installer.
***************************************************** 

Description

Follow these steps to fix this issue:

1. Install a newer version GUN tar. For solaris10 x86 system, for example: tar-1.26-sol10-x86-local.gz.

2. Use the pkgadd -d command to install the package. This release of GNU tar is installed under the directory /user/local/bin.

3. Make sure that this directory has been included in the system environment variable PATH:

env | grep PATH

export PATH=$PATH:/usr/local/bin

4. Make a gtar link to this release of tar:

ln -s /usr/local/bin/tar /usr/local/bin/gtar

5. Verify that gtar is working now:

gtar 
which gtar

Additional Information

Here are the different outputs from tar and gtar:

bash-3.00# which gtar
/usr/sfw/bin/gtar
gtar: You must specify one of the `-Acdtrux' or `--test-label'  options
Try `gtar --help' or `gtar --usage' for more information.

bash-3.00# which tar
/usr/sbin/tar
bash-3.00# /usr/sbin/tar
Usage: tar {c"r"t"u"x}[BDeEFhilmnopPqTvw@[0-7]][bfk][X...] [blocksize] [tarfile] [size] [exclude-file...] {file " -I include-file " -C directory file}...

Comments

Powered by Zendesk