Pivotal Knowledge Base

Follow

gpcrondump fails to bypass disk space check even with '-b' or '--ddboost' option

Environment

  • 4.2.x
  • 4.3.0, 4.3.1, 4.3.2

Problem

gpcrondump is supposed to bypass the check for available disk space on remote segments if the following conditions are met.

  1. '-b' is given in gpcrondump command line. Or
  2. backup target is Data Domain Boots which means '--ddboost' is specified for gpcrondump command

However, in the affected releases gpcrondump will perform the disk space check even though the above conditions are met.

Example 1 - gpcrondump with '--ddboost' option

Starting... on Sun Aug 10 20:30:01 PDT 2014

20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[INFO]:-Starting gpcrondump with args: -x fm01 -v -z -g -G -a --ddboost -l /backup/gp/logs/tukv2/fm01/20140810
20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Checking if MASTER_DATA_DIRECTORY env variable is set.
20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Obtaining master's port from master data directory
20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[INFO]:-Bypassing disk space checks due to DDBoost parameters
20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Checking config exists: test -e /home/gpadmin/DDBOOST_CONFIG
20140810:20:30:02:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting GpCronDump
......
20140810:20:30:45:406525 gpcrondump:mdw:gpadmin-[INFO]:-Validating disk space
20140810:20:30:45:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting ValidateDiskSpace
20140810:20:30:45:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting ValidateGpToolkit
20140810:20:30:46:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Connecting to dbname=fm01
20140810:20:30:46:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-gp_toolkit exists within database fm01.
20140810:20:30:46:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Ending ValidateGpToolkit
20140810:20:30:46:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Connecting to dbname=fm01
20140810:20:30:47:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting ParallelOperation
20140810:20:30:47:406525 gpcrondump:mdw:gpadmin-[DEBUG]:-[worker0] got cmd: Remote(ValidateSegDiskSpace)
......

Example 2 - gpcrondump with '-b' option

[gpadmin@mdw ~]$ gpcrondump -b -v -x template1
20141015:13:45:44:004308 gpcrondump:mdw:gpadmin-[INFO]:-Starting gpcrondump with args: -b -v -x template1
20141015:13:45:44:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Checking if MASTER_DATA_DIRECTORY env variable is set.
20141015:13:45:44:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Obtaining master's port from master data directory
20141015:13:45:44:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting GpCronDump
......
20141015:13:45:54:004308 gpcrondump:mdw:gpadmin-[INFO]:-Validating disk space
20141015:13:45:54:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting ValidateDiskSpace
20141015:13:45:54:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Connecting to dbname=template1
20141015:13:45:55:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-Starting ParallelOperation
20141015:13:45:55:004308 gpcrondump:mdw:gpadmin-[DEBUG]:-[worker0] got cmd: Remote(ValidateSegDiskSpace)
......

Cause
This is a software bug with gpcrondump.

Solution
The bug is fixed as of Pivotal Greenplum Database 4.3.3.0. Please upgrade database to 4.3.3.0 or later to fix this issue.

Comments

Powered by Zendesk