Pivotal Knowledge Base

Follow

gpstart fails with "gpstart error: Catalog Versions are incompatible"

Problem

Pivotal Greenplum database starts fails with the below error message.

[gpadmin@gpdev01 gpAdminLogs]$ gpstart -aR
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-Starting gpstart with args: -aR
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-Gathering information and validating the environment...
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-Greenplum Binary Version: 'postgres (Greenplum Database) 4.3.2.1 build 2'
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-Greenplum Catalog Version: '201310150'
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-MASTER_DIRECTORY Catalog Version: '201109210'
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[INFO]:-Catalog Version of master directory incompatible with binaries
20141113:18:59:47:028367 gpstart:gpdev01:gpadmin-[ERROR]:-gpstart error: Catalog Versions are incompatible
[gpadmin@gpdev01 gpAdminLogs]$

Cause

As the ERROR suggest, there is a mismatch of GPDB catalog version, which basically means that the database is started with a wrong GPDB binaries.

Solution

Source the correct database binaries that the database was built ( for example in the above error the database was built on 4.2.5.2 and we are attempting to start on 4.3.2.1 binaries ) and try to restart the database again.

Comments

Powered by Zendesk