Pivotal Knowledge Base

Follow

Setting DDBoost Credentials results in "[ERROR]:-libCSP-lb.so was not found. Can't set ddboost credentials"

Problem

Attempting to setup Data Domain credential on the Pivotal GreenPlum DataBase cluster results in the below error message

20150401:08:16:48|ddboost-[ERROR]:-libCSP-lb.so was not found. Can't set ddboost credentials

The complete error message looks like

[gpadmin@xxxxx shell]$ gpcrondump -a --ddboost-host xxxx.corp.fin --ddboost-user ddboost --ddboost-backupdir db_dumps

20150401:08:16:22:048969 gpcrondump:gpdev1:gpadmin-[INFO]:-Starting gpcrondump with args: -a --ddboost-host xxxx.corp.fin --ddboost-user ddboost --ddboost-backupdir db_dumps
Password:
20150401:08:16:29:048969 gpcrondump:gpdev1:gpadmin-[INFO]:-Found existing local Data Domain configuration:
20150401:08:16:29:048969 gpcrondump:gpdev1:gpadmin-[INFO]:-     Hostname: xxxx.corp.fin
20150401:08:16:29:048969 gpcrondump:gpdev1:gpadmin-[INFO]:-     Default Backup Directory: db_dumps

Do you want to replace this configuration? Yy|Nn (default=N):
> y
[xxxxx.corp.fin] 20150401:08:16:48|ddboost-[ERROR]:-libCSP-lb.so was not found. Can't set ddboost credentials
20150401:08:16:36:048969 gpcrondump:gpdev1:gpadmin-[ERROR]:-problem delivering config, host: xxxx.corp.fin
[gpadmin@xxxx shell]$

Cause

The cause of the problem is due to missing of rpm "compat-libstdc*" on the cluster.

[gpadmin@xx ~]$ rpm -qa | grep compat-libstdc
compat-libstdc++-33-3.2.3-69.el6.x86_64
[gpadmin@xx ~]$ ssh sdw1
Last login: Wed Apr  1 08:11:47 2015 from mdw
[gpadmin@xx ~]$ rpm -qa | grep compat-libstdc
[gpadmin@xx ~]$ ssh sdw3
Last login: Wed Apr  1 08:36:57 2015 from mdw
[gpadmin@xx ~]$ rpm -qa | grep compat-libstdc
[gpadmin@xx ~]$

Solution

Install the rpm ( attached to the article ) on all the host that are participating to form a Pivotal GPDB cluster and retry the command again to setup DDBoost

To install rpm use

rpm -ivh <rpm-file-name>

Comments

Powered by Zendesk