Pivotal Knowledge Base

Follow

Deploying 2.1 with Isilon may get Operation Error: property should not be present

Environment

  • PHD 2.1
  • Isilon 7.x

Symptom 

icm_client deploy -c clusterConfigDir
Verifying input

[ERROR] Failed to deploy the cluster. Reason: Server error:
Return Code : 1000
Message : Validation Error
Details :
Admin Host :
        Operation Code : CLUSTER_ACTION_VALIDATION
        Operation Error : [hdfs-site.xml: property should not be present:  key=dfs.namenode.rpc-address.${nameservices}.${namenode1id}, value=null, hdfs-site.xml: property should not be present:  key=dfs.namenode.shared.edits.dir, value=null, hdfs-site.xml: property should not be present:  key=dfs.client.failover.proxy.provider.${nameservices}, value=null, hdfs-client.xml: property should not be present:  key=dfs.client.failover.proxy.provider.${nameservices}, value=null, hdfs-client.xml: property should not be present:  key=dfs.nameservices, value=null, clusterConfig.xml: property should not be present:  key=journalport, value=, hbase-site.xml: property value is incorrect: key=hbase.rootdir, value=hdfs://${namenode}:${dfs.port}/apps/hbase/data, clusterConfig.xml: property should not be present:  key=journalpath, value=, clusterConfig.xml: property should not be present:  key=namenode1id, value=, hdfs-client.xml: property should not be present:  key=dfs.namenode.http-address.${nameservices}.${namenode1id}, value=null, hdfs-client.xml: property should not be present:  key=dfs.ha.namenodes.${nameservices}, value=null, core-site.xml: property value is incorrect: key=fs.defaultFS, value=hdfs://${namenode}:${dfs.port}, hdfs-client.xml: property should not be present:  key=dfs.namenode.rpc-address.${nameservices}.${namenode1id}, value=null, hdfs-client.xml: property should not be present:  key=dfs.namenode.rpc-address.${nameservices}.${namenode2id}, value=null, hdfs-site.xml: property should not be present:  key=dfs.namenode.rpc-address.${nameservices}.${namenode2id}, value=null, hdfs-site.xml: property should not be present:  key=dfs.namenode.http-address.${nameservices}.${namenode2id}, value=null, hawq/gpinitsystem_config: Following property should be present for non HA enabled clusters: DFS_URL=${namenode}:${dfs.port}/hawq_data, hdfs-site.xml: property should not be present:  key=dfs.nameservices, value=null, clusterConfig.xml: property should not be present:  key=nameservices, value=, hdfs-site.xml: Did not find property dfs.namenode.secondary.http-address, hdfs-site.xml: property should not be present:  key=dfs.ha.automatic-failover.enabled, value=null, hdfs-client.xml: property should not be present:  key=dfs.namenode.http-address.${nameservices}.${namenode2id}, value=null, hdfs-site.xml: property should not be present:  key=dfs.namenode.http-address.${nameservices}.${namenode1id}, value=null, core-site.xml: property should not be present:  key=ha.zookeeper.quorum, value=null, clusterConfig.xml: property should not be present:  key=namenode2id, value=, hdfs-site.xml: property should not be present:  key=dfs.ha.namenodes.${nameservices}, value=null, yarn-site.xml: property value is incorrect: key=mapreduce.job.hdfs-servers, value=hdfs://${namenode}:${dfs.port}]
        Log File : /var/log/gphd/gphdmgr/gphdmgr-webservices.log

Cause 

In PHD 2.1 High Availability is enabled by default. It will need to be disabled.

Fix 

Refer to the documentaion for disabling High Availability.

Run the icm_client deploy option.

Comments

Powered by Zendesk