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"Server error, status code: 400, error code: 170001, message: Staging error: no available stagers" seen when deploying apps to Pivotal Cloud Foundry®

Environment

Product Version
Pivotal Cloud Foundry®(PCF) Elastic Runtime 1.2.x, 1.3.x, 1.4.x

 

Symptom 

Deploying apps to Pivotal Cloud Foundry (PCF) fails, error message "Server error, status code: 400, error code: 170001, message: Staging error: no availablestagers" is received from the PCF API endpoint. Here is an example of "cf start":

cf start myapp
Starting app myapp in org myorg / space myspace as myaccount...
FAILED
Server error, status code: 400, error code: 170001, message: Staging error: no available stagers

Cause

There is insufficient resource (disk or RAM space) on DEAs (Droplet Execution Agents) to stage the app. When the app is pushed to PCF, PCF tries to find a DEA that has sufficient resource to stage it first. However, if all DEAs are running at high resource usage, there might be no single DEA with enough resource, especially RAM. In that case, PCF returns the error message shown above.

Resolution

The DEA space and numbers should be increased when there are an increasing number of apps deployed on PCF. This problem can be resolved by:
1) increasing DEA RAM size
or
2) adding additional DEA
via Ops Manager. It is recommended to add additional DEAs rather than increase DEA RAM size infinitely because, in that way, there will be too many running apps being hosted on a single DEA.  

If you'd like to check current DEA usage, please refer Pivotal Ops Metrics which reports four data values (available_disk_ratio, available_memory_ratio, mem_free_bytes, mem_used_bytes) for each DEA instance. 

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