Pivotal Knowledge Base

Follow

DCA v2 NTP is not syncing with custom external NTP servers

Environment

  • DCA V1
  • 2.1.0.0

Symptom

NTP Is not syncing with NTP servers external from the DCA even after running dca_setup. As per below output we see ntp on mdw is using the default fudge server which is a loopback time sync

[root@mdw ~]# /usr/sbin/ntpq -pn
     remote           refid      st t when poll reach   delay   offset  jitter
==============================================================================
*127.127.1.0     .LOCL.          10 l   38   64  377    0.000    0.000   0.000
 64.113.32.5     .INIT.          16 u    - 1024    0    0.000    0.000   0.000

Cause

By default /etc/ntp.conf has the following servers enabled

server 127.127.1.0 # local clock
fudge 127.127.1.0 stratum 10

Also NTP is configured to listen on the eth0 interface which is the internal admin network

/etc/sysconfig/ntpd
Drop root to id 'ntp:ntp' by default.
OPTIONS="-u ntp:ntp -p /var/run/ntpd.pid -g -I eth0"

Fix

  • Comment out the references to 127.127.1.0 lines in /etc/ntp.conf
    #server 127.127.1.0 # local clock
    #fudge 127.127.1.0 stratum 10
  • Configure NTP to listen on all interfaces by removing "-I eth0". Optionally you could append "-I bond1" instead of removing eth0 so you ensure NTP listens on both admin and external interfaces only.
    /etc/sysconfig/ntpd
    Drop root to id 'ntp:ntp' by default.
    OPTIONS="-u ntp:ntp -p /var/run/ntpd.pid -g -I eth0"

For Pivotal internal reference see JIRA DCA-10307

Troubleshooting resources

DCA Network Time Protocol (NTP)

Comments

Powered by Zendesk