Pivotal Knowledge Base

Follow

Installation of Greenplum Workload Manager fails with the message "hosts require bootstrap operation"

Environment

Product Version
Pivotal Greenplum (GPDB) 4.3.x
OS RHEL 6.x
Pivotal command center   2.0

Symptom

The installation of the Greenplum Workload Manager results in the error message shown below:

Sun Feb  7 10:36:30 UTC 2016 0 hosts require bootstrap operation.
[Sun Feb  7 10:36:30 UTC 2016] Failure on Sun Feb  7 10:36:30 UTC 2016.
Installation of workload manager failed.

The complete error message is as follows:

[gpadmin@localhost bin]$ gpcmdr --setup

An instance name is used by the Greenplum Command Center as
a way to uniquely identify a Greenplum Database that has the monitoring
components installed and configured.  This name is also used to control
specific instances of the Greenplum Command Center web UI.  Instance names
can contain letters, digits and underscores and are not case sensitive.

Please enter a new instance name:
> gpcc
The web component of the Greenplum Command Center can connect to a
monitor database on a remote Greenplum Database.


Is the master host for the Greenplum Database remote? Yy|Nn (default=N):
> n
The display name is shown in the web interface and does not need to be
a hostname.
        

What would you like to use for the display name for this instance:
> gpcc
What port does the Greenplum Database use? (default=3000):
>  
Creating instance schema in GPDB.  Please wait ...
The display name is shown in the web interface and does not need to be
a hostname.
        


Would you like to install workload manager? Yy|Nn (default=N):
> y
Installing workload manager to /home/gpadmin. Please wait...
[Sun Feb  7 10:36:27 UTC 2016] Installation started.
[Sun Feb  7 10:36:27 UTC 2016] No previous installation detected; performing first-time install of version 1.0.3.
[Sun Feb  7 10:36:27 UTC 2016] Decompressing archive.
[Sun Feb  7 10:36:28 UTC 2016] Configuring components (stage 1)
[Sun Feb  7 10:36:28 UTC 2016] Configuring agent
[Sun Feb  7 10:36:28 UTC 2016] Configuring agent plugin gpdb_stats.so
[Sun Feb  7 10:36:28 UTC 2016] Configuring agent plugin gpdb_throttle.so
[Sun Feb  7 10:36:28 UTC 2016] Configuring agent plugin pthrottle.so
[Sun Feb  7 10:36:28 UTC 2016] Configuring agent plugin systemdata.so
[Sun Feb  7 10:36:28 UTC 2016] Configuring cfgmon
[Sun Feb  7 10:36:28 UTC 2016] Configuring cfgmon plugin gpdb_clustermon.so
[Sun Feb  7 10:36:28 UTC 2016] Configuring init scripts
[Sun Feb  7 10:36:28 UTC 2016] Configuring gptop
[Sun Feb  7 10:36:29 UTC 2016] Configuring kraken-bootstrap
[Sun Feb  7 10:36:29 UTC 2016] Configuring rabbitmq
[Sun Feb  7 10:36:29 UTC 2016] Configuring rulesengine
[Sun Feb  7 10:36:29 UTC 2016] Configuring components (stage 2)
[Sun Feb  7 10:36:29 UTC 2016] Configuring agent plugin gpdb_record.so
[Sun Feb  7 10:36:29 UTC 2016] Configuring agent plugin gpdb_throttle.so
[Sun Feb  7 10:36:29 UTC 2016] Configuring cfgmon
[Sun Feb  7 10:36:29 UTC 2016] Configuring cfgmon plugin gpdb_clustermon.so
[Sun Feb  7 10:36:29 UTC 2016] Configuring gptop
[Sun Feb  7 10:36:30 UTC 2016] Configuring kraken-bootstrap
[Sun Feb  7 10:36:30 UTC 2016] Configuring rabbitmq
[Sun Feb  7 10:36:30 UTC 2016] Configuring rulesengine
[Sun Feb  7 10:36:30 UTC 2016] Ensuring services are stopped.
Sun Feb  7 10:36:30 UTC 2016 0 hosts require bootstrap operation.
[Sun Feb  7 10:36:30 UTC 2016] Failure on Sun Feb  7 10:36:30 UTC 2016.
Installation of workload manager failed.

Cause

The issue is due to a difference in hostnames in the database:

postgres=# select * from gp_segment_configuration ;
 dbid | content | role | preferred_role | mode | status | port  |       hostname        |        address        | replication_port | san_mounts
------+---------+------+----------------+------+--------+-------+-----------------------+-----------------------+------------------+------------
    1 |      -1 | p    | p              | s    | u      |  3001 | localhost.localdomain | 127.0.0.1             |                  |
    2 |       0 | p    | p              | s    | u      | 30003 | localhost.localdomain | localhost.localdomain |                  |
    3 |       1 | p    | p              | s    | u      | 30004 | localhost.localdomain | localhost.localdomain |                  |
(3 rows)

And on Unix:

[gpadmin@localhost ~]$ hostname -s
localhost
[gpadmin@localhost ~]$ hostname -f
localhost.localdomain
[gpadmin@localhost ~]$ hostname
localhost

This difference caused the installer to believe that it needed install to another host. Currently, there is a improvement being worked on to fix this issue (bug CMDR-1990).

Resolution

Sync the hostname of Unix to that of the database.

  • To sync up the "hostname -f" command,  ensure that the hostname you want to have is in place soon after the line of IP.

For example, we want to have "gpdbsne" as the hostname, so we place the name soon after the IP address.

[root@gpdbsne ~]# cat /etc/hosts
127.0.0.1   gpdbsne localhost localhost.localdomain localhost4 localhost4.localdomain4 gpdbsne
::1         gpdbsne localhost localhost.localdomain localhost6 localhost6.localdomain6 gpdbsne
[root@gpdbsne ~]# 
  • For syncing up "hostname" & "hostname -s":

If it is a DCA, then change the hostname as the following:

DCA v1

  1. Stop the database.
  2. Run dca_setup.
  3. Choose option 2 > Modify DCA settings.
  4. Choose option 14 > Networking: Segments.
  5. Choose option 2 > Edit DCA Hostnames.
  6. Change hostname to the new hostname and apply the changes.

DCA v2

  1. Stop the database.
  2. Run dca_setup.
  3. Choose option 2 > Modify DCA settings.
  4. Choose option 14 > Modify Hostnames.
  5. Follow the one-screen instruction to change the hostname.
  • If it is not a DCA, check with the system admin of the organization to change the hostname to that on the database by editing the file shown below.
vi /etc/sysconfig/network

And then try the Greenplum Workload Manager installation.

Comments

Powered by Zendesk