Pivotal Knowledge Base

Follow

Apache Knox Gateway showing "Heartbeat Lost" in Ambari with Pivotal HD

Environment

Product Version
Pivotal HD 3.0.x
Ambari 2.1.2
Apache Knox Gateway (Knox)  0.5.0

Symptom

The Apache Knox Gateway (Knox) appears to be working correctly, but Ambari reports the Knox Gateway status as "Heartbeat Lost":

Cause

The Ambari agent is out of date on the affected Knox Gateway node causing this reporting issue:

[root@phd301 ~]# rpm -qa | grep ambari-server
ambari-server-2.1.2.2-163.x86_64
[root@phd301 ~]# ssh dn1
Last login: Wed Apr 6 11:04:00 2016 from phd301.lab
[root@dn1 ~]# rpm -qa | grep ambari-agent
ambari-agent-1.7.1-87.x86_64
[root@dn1 ~]# 

Resolution

Upgrade the Amabri agent on the affected node by following the steps outlined in the Ambari upgrade documentation. The steps will be similar to this:

1. Confirm that the available Ambari repository is up to date:

[root@phd301 ~]# yum repolist
Loaded plugins: fastestmirror, security
Repository PHD-UTILS-1.1.0.20 is listed more than once in the configuration
Loading mirror speeds from cached hostfile
* base: mirror.mhd.uk.as44574.net
* extras: mirror.mhd.uk.as44574.net
* updates: mirrors.clouvider.net
repo id repo name status
AMBARI-2.1.2.2 AMBARI-2.1.2.2 6
PADS PADS 6
PHD-3.0 PHD-3.0 143
PHD-3.0.1.0 PHD-3.0.1.0 143
PHD-UTILS-1.1.0.20 PHD-UTILS-1.1.0.20 41
base CentOS-6 - Base 6,575
extras CentOS-6 - Extras 62
hawq-plugin-phd-1.3.1 hawq-plugin-phd-1.3.1 1
updates CentOS-6 - Updates 111
repolist: 7,088
[root@phd301 ~]#

If the Ambari repository version is incorrect, review the Ambari upgrade document (Step 8) to make sure that the latest repository is being used.

2.Stop the Ambari agent.

ambari-agent stop 

3.Update to the latest Ambari version

For RHEL:

yum upgrade ambari-agent

For SLES: 

zypper up ambari-agent

4. Restart ambari-agent.

ambari-agent start


 

Comments

Powered by Zendesk