Pivotal Knowledge Base

Follow

Error "XX000, could not connect to the primary server: FATAL: invalid command-line argument for server process"

Environment

  • Pivotal Greenplum Database (GPDB) 4.3.x
  • Operating System- Red Hat Enterprise Linux 6.x

Purpose

This article explain on issues in configuring Master (mdw) and Standby (smdw) servers. Similar searches are explained on below link:

Link to Fault-Tolerance-and-Segment-recovery

This is specific to one particular Error :

"ERROR","XX000","could not connect to the primary server: FATAL:  invalid command-line argument for server process: dbname=replication (gp_libpqwalreceiver.c:81)","HINT:  Try ""postgres --help"" for more information.",,,,,,0,,"gp_libpqwalreceiver.c",81

Symptom

Invalid entries in recovery.conf file placed under Standby (smdw) data directory with entries related to "client_min_messages=ERROR"

Resolution

  • Checked to see the recovery.conf file placed under standby master data directory causing the issue.
  • File had entry related to "client_min_messages=ERROR"
  • Removed Invalid entries from that file.

  • Check the mdw and smdw process status for a while. If there are no active transactions then try to perform preliminary tests (to be sure it generates the transaction to track the status)
  • Standby master and master are in sync.

Comments

  • Avatar
    Amitabh Kumar

    Thanks for helpful article. I had a very similar issue (SR# 78897402) on version 4.3.5.2 where standby showing the same error message. Got similar entry in recovery.conf file with a difference of options=''-c gp_session_role=utility''. Following this article, removed the entry and it worked.

  • Avatar
    Scott Gai

    Similar error was seen with SR 78108890. An extra entry found in .bashrc on standby master host.

    export PGOPTIONS='-c gp_session_role=utility'

Powered by Zendesk