Pivotal Knowledge Base

Follow

"Failed to acquire resources on one or more segments" error message seen in Pivotal Greenplum

Environment

Product Version
Pivotal Greenplum (GPDB) 4.3.x
OS RHEL 6.x
Others  

Symptom

When running a query, sometimes it may fail with the following error message:

ERROR","58M01","failed to acquire resources on one or more segments",

On further investigation in the log file you may see the following error messages:

2016-03-17 16:31:53.967397 BST,"user1","piv-test",p2852,th-443540096,"10.123.4.51","649",2016-03-17 16:31:28 BST,6871201,con9,cmd2,seg-1,,dx113,x6871201,sx1,"LOG","58M01","Master unable to connect to entry db flightdata:5432 with options fe_sendauth: no password supplied",,,,,,"CREATE TABLE piv-sch.query_test AS SELECT * FROM information_schema.tables where table_name='test_input' and table_schema=piv-sch'

2016-03-17 16:31:53.967568 BST,"user1","piv-test",p2852,th-443540096,"10.123.4.51","649",2016-03-17 16:31:28 BST,6871201,con9,cmd2,seg-1,,dx113,x6871201,sx1,"ERROR","58M01","failed to acquire resources on one or more segments",,,,,,"CREATE TABLE piv-sch.query_test AS SELECT * FROM information_schema.tables where table_name='test_input' and table_schema=piv-sch'

Resolution

These messages are error messages that are related to a bug that has been identified. This is related to the Query Dispatcher (QD) process on the Master. It shows issues for the connection for the QD process on the master connecting to the postmaster process on the master.

To alleviate this issue, you can change the parameter gp_reject_internal_tcp_connection to "off". The default value for this parameter is "on". This parameter is used for permitting internal TCP connections to the master. Ideally, the UNIX domain socket should be used instead of a TCP connection, that is why the default value for the parameter gp_reject_internal_tcp_connection is "on". Due a change made recently in the code, the UNIX domain is not chosen, so that is why these LOG messages are encountered.

This parameter is a restricted parameter and when setting this parameter, you will need to use the "--skipvalidation" value. To set the parameter, you will need to run the following:

gpconfig -c gp_reject_internal_tcp_connection -v off --skipvalidation

Note: After setting this parameter, the database will need to be restarted.

This issue should be fixed in a future release of Pivotal Greenplum. 

Internal Comments

Ref: MPP-26394.

 

 

Comments

Powered by Zendesk