Pivotal Knowledge Base

Follow

Unsupported major.minor version 52.0 error seen when installing Spring Cloud Services

Environment

Product Version
Spring Cloud Services 1.0.x

Symptom

When attempting to upgrade or install Spring Cloud Services, the installation fails with the following message:

{"type": "step_finished", "id": "errands.running.p-spring-cloud-services-a978fc8f45f9b12fd913.deploy-service-broker"}
Exited with 1.

Error Message:

Checking further on the Spring Cloud Services log by running the following command:

cf logs spring-cloud-broker --recent

would contain the error log messages shown here:

2015-08-27T05:20:25.94-0400 [App/0] ERR Exception in thread "main" java.lang.UnsupportedClassVersionError: io/pivotal/springcloud/servicebroker/Application : Unsupported major.minor version 52.0

Cause 

This error is shown if the prerequisite of the Java buildpack of at least 2.5 or higher is not detected. 

Resolution

Follow these steps to resolve this issue:

  1. Run cf buildpacks  
  2. Check if you havebuildpack 2.5 (or higher):
    cf buildpacks
    Getting buildpacks...
    
    buildpack                position   enabled   locked   filename   
    java_buildpack_offline   1          true      false    java-buildpack-offline-v3.0.zip 
  3. If you have multiple Java buildpacks, make sure Java buildpack 2.5 (or higher) has a higher position i.e. 1 than the older Java buildpack.
  4. Run bosh run errand deploy-service-broker to deploy the Spring Cloud Service Broker.

Comments

Powered by Zendesk