Pivotal Knowledge Base


Upgrading JMX Bridge 1.7 from 1.6 fails to detect pointed stemcell in Pivotal Cloud Foundry


Product Version
Pivotal Cloud Foundry® (PCF)  
Ops Metrics 1.6.15
JMX Bridge  1.7
Ops Manager   Ops Manager 


When attempting an upgrade from Ops Metrics 1.6.15 to JMX Bridge 1.7, the installation fails with the error message below even though you already have 3232.12 installed. 

Error Message:

This product requires a stemcell that is older than the currently installed product. Download the newest version of this product from Pivotal Network and try again.


The Ops Metrics version 1.6.15 metadata contains stemcell pointed version '3232.12':

   os: ubuntu-trusty
   version: '3232.12'
   requires_cpi: false

While JMX Bridge version 1.7 requires a floating version of '3232' stemcell:

   os: ubuntu-trusty
   version: '3232'
   requires_cpi: false

Going from a pointed stemcell i.e. '3232.12' from PCF 1.6 or earlier to a floating stemcell i.e. '3232' will cause the error if using Ops Manager versions prior to 1.7.8. This is a bug in Ops Manager that was fixed in version 1.7.8.


Follow the steps to resolve this issue:

  1. Connect via SSH into Ops Manager.
  2. Locate the JMX v1.7.2 metadata file with command.

    sudo grep -C 1 p-metrics /var/tempest/workspaces/default/metadata/*

  3. You may see multiple files listed in the output from the previous command.  Look for the file where you see 'name: p-metrics' and 'version: xxxx' where 'xxxx' matches your version of the the JMX Bridge Tile."
    /var/tempest/workspaces/default/metadata/f95b3d167e28.yml:- name: p-metrics
    /var/tempest/workspaces/default/metadata/f95b3d167e28.yml-  version: 1.7.2
  4. Modify the metadata's stemcell. In this example, edit the file:


    Change the stemcell_criteria version from version: '3232' to version: '3232.12'

    os: ubuntu-trusty
    version: '3232.12'
    requires_cpi: false
  5. Retry the upgrade.



Powered by Zendesk