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Deploy and Register Autoscaling Service Broker Errand fails during Elastic Runtime installation

Environment

Product Version
Pivotal Elastic Runtime 1.7

Symptom

When attempting to install or upgrade to Pivotal Elastic Runtime (ERT) 1.7, the installation fails with an error message similar to the one shown below:

Error Message:

API endpoint:   https://api.system.<domain> (API version: 2.54.0)
User:           admin
Org:            system
Space:          autoscaling
Creating service broker app-autoscaler as admin...
FAILED
Server error, status code: 502, error code: 10001, message: The service broker rejected the request to https://autoscale.system.<domain> /v2/catalog. Status Code: 404 Not Found, Body: 404 Not Found: Requested route ('autoscale.system.<domain>') does not exist.

===== 2016-07-27 11:41:16 UTC Finished "bundle exec bosh -n run errand autoscaling-register-broker"; Duration: 119s; Exit Status: 1
{"type": "step_finished", "id": "errands.running.cf-df674eb7a993fdeff4b3.autoscaling-register-broker"}
Exited with 1.

Cause 

The error indicates that the autoscale app was either not deployed successfully, not started or route was not successfully created.

Resolution

Follow the steps to resolve this issue:

  1. Log on Apps Manager using the following command
    cf login
  2. Select the org as "system" and the space as autoscaling
    cf target -o system -s autoscaling
  3. Check the status of the apps under the autoscaling space using
    cf apps
  4. Start any application that is down using
    cf start <APPNAME>
  5. Check the status of the apps, if they are already up and running using
    cf apps
  6. If any of the apps do not start successfully, contact Pivotal Support and provide the result of
    cf logs autoscale --recent

 

 

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