Pivotal Knowledge Base


Import from 1.7 Fails in the Ops Manager 1.8 with the message, "Product is not Compatible with your current version of Ops Manager"


Pivotal Cloud Foundry Version 1.7.x upgraded to the Version 1.8.x


When upgrading from Pivotal Cloud Foundry version 1.7.x to version 1.8.x, you may see the following error message while trying to import the configuration from PCF 1.7.x.

Cannot generate manifest for product [tile name]: Error in ((availability_zone)): This product is not compatible with your current version of Ops Manager.  To resolve, please remove the product or upgrade it to a newer version that supports this version of Ops Manager. (Product "[tile name]" / Job: nil)


There have been changes made in Ops Manager 1.8 which break compatibility with older tiles. This error message is indicating that an incompatible tile was present when the Ops Manager 1.7.x configuration was exported.  


Go back to Ops Manager 1.7.x and either delete or upgrade the offending tile.  Then click 'Apply Changes' and wait for it to complete successfully. Once done, export the tile again, and continue on with the upgrade process.

To determine if a tile is compatible with the Ops Manager 1.8, you can refer to the Compatibility Matrix, look at the tile description on the Pivotal Network, or look at the documentation for the tile.  

If you need assistance in determining if a tile is compatible with PCF 1.8 or have trouble uninstalling or upgrading a tile to a compatible version, please open a support ticket for further assistance.


Powered by Zendesk