Pivotal Knowledge Base

Follow

GPCC shows grey login page and message "Greenplum database is down. Contact database administrator to start it"

Environment

Product Version
Pivotal Greenplum (GPDB) 4.3.x
Pivotal Greenplum Command Center (GPCC) 2.x
OS All OS
Others  

Symptom

When loading the webpage of one GPCC instance, it shows gray login page with a message “Greenplum database is down. Contact database administrator to start it.”

Error Message:

Following is a screenshot which illustrates the problem.

 

Cause

The GPCC instance is managing a remote GPDB cluster and it fails to get cluster state by run some command remotely on the master host of GPDB cluster via ssh.

RCA

Upon being loaded GPCC web console will keep checking if the GPDB cluster is running or not by executing below command. 

ssh -o "StrictHostKeyChecking no" master_hostname "ls -1 /tmp/.s.PGSQL.master_port | grep PGSQL"

Note: Replace master_hostname and master_port with settings configured in gpperfmonui.conf of GPCC instance. For example,

[gpadmin@mdw conf]$ cat gpperfmonui.conf 
[WEB APP]
......
master_port = 5432
master_hostname = 10.152.9.24 ......

The ssh command requires password-less login to remote GPDB master host. However, password-less login is not setup in this case so it fails to run ssh command and returns error. Hence the problem occurs.

Resolution

Follow the steps to resolve this issue:

  1. Setup password-less login to remote GPDB master host if it has not been done.
  2. Once password-less login is working normally, run the ssh command as illustrated below and verify a successful result
[gpadmin@mdw conf]$ ssh -o "StrictHostKeyChecking no" 10.152.9.24 "ls -1 /tmp/.s.PGSQL.5432 | grep PGSQL"
/tmp/.s.PGSQL.5432 

 

Comments

Powered by Zendesk