Pivotal Knowledge Base

Follow

Pivotal Elastic Runtime 1.7.20 Upgrade Incompatibility

Environment

  Product   Version

 Pivotal Cloud Foundry® (PCF) Elastic Runtime 

 

  1.7.20

  

 

Symptom

While upgrading to PCF Elastic Runtime 1.7.21, 1.7.22, 1.7.23, 1.8.0, 1.8.1, 1.8.2, 1.8.3, 1.8.4 and 1.8.5, from version 1.7.20, the installation fails for UAA partition job with the following exceptions:

Caused by: java.sql.SQLSyntaxErrorException: Unknown column 'version_rank' in 'field list' 
at org.mariadb.jdbc.internal.SQLExceptionMapper.get(SQLExceptionMapper.java:138)
at org.mariadb.jdbc.internal.SQLExceptionMapper.throwException(SQLExceptionMapper.java:106)
at org.mariadb.jdbc.MySQLStatement.executeQueryEpilog(MySQLStatement.java:268)
at org.mariadb.jdbc.MySQLStatement.execute(MySQLStatement.java:296)
at org.mariadb.jdbc.MySQLStatement.executeQuery(MySQLStatement.java:310)

 

Caused by: org.mariadb.jdbc.internal.common.QueryException: Unknown column 'version_rank' in 'field list' 
at org.mariadb.jdbc.internal.mysql.MySQLProtocol.getResult(MySQLProtocol.java:982)
at org.mariadb.jdbc.internal.mysql.MySQLProtocol.executeQuery(MySQLProtocol.java:1042)
at org.mariadb.jdbc.MySQLStatement.execute(MySQLStatement.java:289) 

 

Cause

UAA component of Elastic Runtime 1.7.20 has a known upgrade compatibility issue. So if you have not yet installed Elastic Runtime 1.7.20, please do not install it. Instead, please install or upgrade to one of the recent releases of 1.7.22 or higher, or 1.8.2 or higher. These higher patch releases do not have this upgrade compatibility issue.

 

Resolution

If you have already installed or upgraded to Elastic Runtime 1.7.20, you will have to upgrade to a compatible version of Elastic Runtime, like Elastic Runtime 1.7.24 (or higher releases of 1.7.x) and Elastic Runtime 1.8.6 (or higher releases of 1.8.x).

Please contact Pivotal Support if you have any questions.

 



 

Comments

Powered by Zendesk