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Unable to Delete or Create RabbitMQ Service Instances

Environment 

 Product  Version
 RabbitMQ for Pivotal Cloud  Foundry  1.5.x, 1.6.x, 1.7.x

Overview 

This article provides a troubleshooting guide for when you are unable to delete or create RabbitMQ Service instances.  

Symptom

When attempting to delete or create a RabbitMQ service instance it fails with the error message:

cf delete-service rabbitmq-service-instance
Really delete the service rabbitmq-service-instance?> yes
Deleting servicerabbitmq-service-instance in org ORG / space SPACE as USER..

FAILED
Server error, status code: 502, error code: 10001, message: Service instance order-api-rabbitmqold: The service broker rejected the request to https://pivotal-rabbitmq-broker.domain/v2/service_instances/XXXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXX. Status Code: 404 Not Found, Body: 404 Not Found: Requested route ('pivotal-rabbitmq-broker.domain') does not exist.
 

Cause 

Here are a few reasons for why the RabbitMQ service broker is unable to process the request:

  • RabbitMQ service broker encountered an error during serving the request.
  • RabbitMQ service broker is not up and running.
  • Rabbit VMs are in an unknown state.

Resolution

Here are troubleshooting steps you can take to ensure your RabbitMQ service broker is up and running:

  1. Try running cf purge-service-instance rabbitmq-service-instance to see if that successfully deletes the instance. If not, proceed to the next steps.
  2. Check the health of the VMs by using the command bosh cck. If Bosh CCK did a repair on the Rabbit Tile VMs successfully, try to create/delete RabbitMQ service and see if that resolves the issue. If Bosh CCK reported a problem but is unable to repair it, Please contact Pivotal Support.
  3. If Bosh CCK did not report any problems, go to Ops Manager console -> RabbitMQ Tile -> Status Tab. Check if all the VMs have been assigned to the specific IP. If the IPs show "unknown" under the IP column, create the VMs using  bosh recreate <job> <index>. Try to create or delete the service and see if this resolves the issue. 
  4. Check the jobs in RabbitMQ service broker. Do a monit summary and see if rabbitMQ-broker and broker-route-registar are running:
  • If it is not running, try to run the processes by using monit start <job>. If the job starts successfully, try to create or delete a Rabbit service and see if this resolves the issue.
  • If any of the processes is unable to start successfully, contact Pivotal Support.
  • If the job(s) are already running, check the RabbitMQ service broker logs for errors and contact Pivotal Support.

 

 

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