Pivotal Knowledge Base

Follow

WLM 1.6.0 Installation Error: "getopt: Unrecognized Option Error"

Environment

 Product  Version
 Pivotal Greenplum  4.3.x
 OS  RHEL 6.x
 GPCC  3.0.0
 WLM  1.6.0

Symptom

The following error is seen:

  $ ./gp-wlm-1.6.0.bin --install=/home/gpadmin/ 
[Mon Nov 14 09:56:30 UTC 2016] Installation started.
[Mon Nov 14 09:56:30 UTC 2016] Installer version 1.6.0 is newer than existing version 1.0.3; starting upgrade.
[Mon Nov 14 09:56:31 UTC 2016] Decompressing archive.
[Mon Nov 14 09:56:33 UTC 2016] Configuring components (stage 1)
getopt: unrecognized option `--func-file=/home/gpadmin//gp-wlm-data/.scratch/installer/installer.functions'
[Mon Nov 14 09:56:33 UTC 2016] Failure on Mon Nov 14 09:56:33 UTC 2016.

Cause

There may be left over files from a previous installation of GP-WLM 1.0.3 causing the installation to fail.

Resolution

  • Assuming that /home/gpadmin is the install directory for gp-wlm, please run this command:
ls -al /home/gpadmin/gp-wlm-data
  • If there is a .scratch directory, please move it:
mv /home/gpadmin/gp-wlm-data/.scratch /home/gpadmin/.scratch-gp-wlm-data-failed-install
  • Run the 1.6.0 installer again.

Additional Information

Refer similar issues related to GP-WLM

Comments

Powered by Zendesk