Pivotal Knowledge Base

Follow

Importing Operations Manager configuration fails with OpenSSL Cipher error

Environment

Pivotal Cloud Foundry 1.12

Symptom

Upgrading Operations Manager from 1.11 to 1.12 and possibly other versions.

Restoring Operations Manager configuration from backup.

Importing Operations Manager gets 500 error OpenSSL::Cipher::CipherError.

Error Message:

500 An error occurred.
Contact Pivotal Technical Support to report the problem.

Back to dashboard

OpenSSL::Cipher::CipherError

/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:98:in `final'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:98:in `crypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/encryptor-3.0.0/lib/encryptor.rb:49:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:233:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:317:in `decrypt'
/home/tempest-web/tempest/web/vendor/bundle/ruby/2.3.0/gems/attr_encrypted-3.0.3/lib/attr_encrypted.rb:155:in `block (2 levels) in attr_encrypted'
/home/tempest-web/tempest/web/app/models/uaa/uaa_config_writer.rb:82:in `generate_uaa_yml'

Cause 

This could be due to corrupted installation export or bad decryption passphrase.

Resolution

Follow the steps to resolve this issue:

1. Power off the newly deployed Operations Manager VM.
2. Power on the old Operations Manager VM and login.
3. Click Admin (in upper right corner) and then click Settings.
4. Go to Decryption passphrase and enter a new New decryption passphrase.
5. Go to Export Installation Settings and re-export settings.
6. Power off old Operations Manager VM.
7. Power on the new Operations Manager with 1.12 OVA and re-import using config with new decryption passphrase. 

Comments

Powered by Zendesk