Post

2 followers Follow
1
Avatar

Install madlib package on GPDB 4.3.11.3

Hello,

 

I am attempting to install madlib-ossv1.9.1_pv1.9.6_gpdb4.3orca-rhel5-x86_64.gppkg into GPDB 4.3.11.3 and it fails with the following error on each segment host -

 

20170307:14:42:36:014255 gppkg:xxxxxx:gpadmin-[INFO]:-Starting gppkg with args: -i madlib-ossv1.9.1_pv1.9.6_gpdb4.3orca-rhel5-x86_64.gppkg
20170307:14:42:37:014255 gppkg:xxxxxx:gpadmin-[INFO]:-Installing package madlib-ossv1.9.1_pv1.9.6_gpdb4.3orca-rhel5-x86_64.gppkg
20170307:14:42:37:014255 gppkg:xxxxxx:gpadmin-[INFO]:-Validating rpm installation cmdStr='rpm --test -i /opt/local/greenplum-db-4.3.11.3/.tmp/madlib-1.9.1-1.x86_64.rpm --dbpath /opt/local/greenplum-db-4.3.11.3/share/packages/database --prefix /opt/local/greenplum-db-4.3.11.3'
20170307:14:42:38:014255 gppkg:xxxxx:gpadmin-[ERROR]:-ExecutionError: 'non-zero rc: 2' occured. Details: 'ssh -o 'StrictHostKeyChecking no' xxxx.xxx.xxx.xx ". /opt/local/greenplum-db/./greenplum_path.sh; $GPHOME/sbin/gpoperation.py"' cmd had rc=2 completed=True halted=False
stdout=''
ExecutionError: 'non-zero rc: 1' occured. Details: 'rpm --test -i /opt/local/greenplum-db-4.3.11.3/.tmp/madlib-1.9.1-1.x86_64.rpm --dbpath /opt/local/greenplum-db-4.3.11.3/share/packages/database --prefix /opt/local/greenplum-db-4.3.11.3' cmd had rc=1 completed=True halted=False
stdout=''
stderr='rpm: /opt/local/greenplum-db/./ext/R-3.3.1/extlib/liblzma.so.5: version `XZ_5.1.2alpha' not found (required by /lib64/librpmio.so.3)

 

Has anyone seen this error before?

 

Regards

 

Mark

Mark Schloss

Please sign in to leave a comment.

2 comments

1
Avatar

It looks like your LD_LIBRARY_PATH from your R installation is taking precedence to the system library required by madlib. Try re-arranging your LD_LIBRARY_PATH to point to the R libraries after the Greenplum/system libraries and try the installation again.

Taylor Vesely 1 vote
1
Avatar

Thanks for the update. I changed greenplum_path.sh for the install process to remove the R references from LD_LIBRARY_PATH and the installation went through.

 

Thanks for your help.

 

Regards

 

Mark

Mark Schloss 1 vote