Post

2 followers Follow
0
Avatar

WAN Gateway Replication settings

We are experience slow WAN gateway replication in our multi site topology.
Here are the settings we had in gateway hub tag in cahce.xml:
Batch Interval 1000
Socketbuffersize 229376
Batch Size 100
Concureency Level 6

We changed them to these new values
Batch Interval 10
Socketbuffersize 12582912
Batch Size 1
Concureency Level 24

We see a drastic improvement in replication like around 80%., object size is 5MB.

My question is will this new settings have any other side effects to our GemFire6 cache servers?
Please advise.

Thanks,
Chakri

CHAKRAVARTI

Please sign in to leave a comment.

2 comments

1
Avatar

I think the two main reasons for the improvement are:

  • bigger socket buffers can contain the entire batch (1*5MB). Previously the batch was bigger than the buffer (100*5MB=500MB). You might try a batch size of 2 to see if that does anything.
  • more threads sending batches

The main things I would monitor are the normal resources:

  • CPU on the primary gateway member - more threads processing batches could mean higher CPU
  • network usage on primary gateway member's host - more threads sending batch could mean more network usage (generally this is a good thing, but you should check it)
  • memory usage
    • concurrency-level=24 -vs- 6 creates more queues and more socket buffers which means more memory usage
    • socket-buffer-size= 12582912 also means more memory usage
    • you don't mention the maximum-queue-memory, but now 24 * that value is how much memory the queues could be using so make sure there is enough heap
Barry Oglesby 1 vote
0
Avatar

Thanks for the reply.
We changed the settings like this and added a 2.5 secs delay after put. That gives 100% success.
<gateway-hub id="aaa" socket-buffer-size="229376" >
<gateway id="bbb" socket-buffer-size="229376" concurrency-level="6" order-policy="key">
<gateway-queue disk-store-name="QUEUES" enable-persistence="true" maximum-queue-memory="100" batch-conflation="true" batch-size="100" batch-time-interval="100"/>
We have on gateway to each site.

I want to avoid that 2.5 secs delay after put.
Any help is appreciated.

Again thanks for helping on this.

Thanks,
Chakri

CHAKRAVARTI 0 votes