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永続化ディスクが Director VM にマウントされていない

環境

製品

バージョン
Pivotal Cloud Foundry®(PCF) 1.6

事象

永続化ディスクがデプロイした Director VM にマウントさていない(/var/vcap/store)。

その際、以下のようなエラーメッセージが発生している。

/home/tempest-web/tempest/web/vendor/bundle/ruby/2.2.0/gems/bosh_vsphere_cpi-2.2.0/lib/
cloud/vsphere/cloud.rb:348:in `block in detach_disk': Disk
'disk-a2971b65-8c2b-41f4-86e3-c0cbe6a98948' is not attached to VM
'vm-351eb059-ccaa-4ad0-88de-8dac566bc6d5' (Bosh::Clouds::DiskNotAttached) 

原因

このエラーは、いくつかの異なる理由で発生する可能性がある。もっとも一般的な原因は、IaaS レベルでユーザーやスクリプト、自動化機構により、当該仮想マシン(VM)からディスクがアンマウントされたか、BOSH で前回のデプロイ処理にて想定外の停止や失敗が発生した場合である。問題の発生タイミングにもよるが、BOSH が当該 VM に依然としてディスクがマウントされているという間違った状態を保持しており、後続のディスクアンマウント処理に失敗することによるものである。 

これは IaaS に依存する問題ではなく、また Director に限らず永続化ディスクをマウントするような任意の VM を BOSH でデプロイしている場合にも発生し得る。

解決策

使用している IaaS 環境で、対象の永続化ディスクが見つけることができるか確認すること。各データストアをブラウズし、当該永続化ディスクの名前から見つけることができるであろう。当該ディスクはアンマウントされており、Director VM とは別個に存在する。

注意: 当該永続化ディスク自体が存在していることが大変重要である。

当該永続化ディスクが存在しない場合は、以下の手順に従うこと。

  1. 使用している IaaS 環境で、古い Director VM をシャットダウンする。
  2. Ops Manager VM に SSH でログオンする。そして、以下のディレクトリに cd にて移動する。
    /var/tempest/workspaces/default/deployments.
  3. bosh_deployments.yml のバックアップコピーを取得し、編集する(バックアップコピーではなく実ファイルを編集)。
  4. vm_cid の行を見つける。ここにはグローバル識別子(GUID)が設定されており、これが使用している IaaS における Director VM の名前である。当該行全てを削除し保存、ファイルを閉じる。
  5. Ops Manager Web UI にアクセスし、"Apply Changes" をクリックする。これにより、Director のため新しい VM が生成される。
  6. /var/tempest/workspaces/default/deployments/bosh-deployments.yml ファイルの vm_cid に新しい GUID を設定し、当該ファイルを更新する。
  7. インストールが完了したら、まずは古い Director VM を削除し、次に bosh_deployments.yml のバックアップコピーを削除する。

上記手順によっても問題が解決しない場合は、support.pivotal.io から PCF サポートに問い合わせされたい。

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